SticiGui requires an up-to-date standards-compliant browser. I recommend Mozilla Firefox21.x or higher. Current versions of Safari and Google Chrome work with most of the materials. I do not recommend Microsoft Internet Explorer.

In summary, you need:


Not only must your browser support JavaScript, but it must be enabled, and your browser needs to accept cookies from the originating server.